【Flutter】CocoaPods could not find compatible versions for pod "FirebaseFirestore": の対処法

FlutterFire公式ドキュメントを参考にCloud Firestore導入していたところ、iOSアプリのビルド時間を短くするのに以下のコードが有効らしくドキュメントの指示通りコードをPodfileに追加。

pod 'FirebaseFirestore', :git => 'https://github.com/invertase/firestore-ios-sdk-frameworks.git', :tag => '8.15.0'

しかしながら、iOSエミュレーターをビルドしたら以下のエラーが発生。

CocoaPods could not find compatible versions for pod "FirebaseFirestore":
  In Podfile:
    FirebaseFirestore (from `https://github.com/invertase/firestore-ios-sdk-frameworks.git`, tag `8.15.0`)

    cloud_firestore (from `.symlinks/plugins/cloud_firestore/ios`) was resolved to 3.4.3, which depends on
      Firebase/Firestore (= 9.3.0) was resolved to 9.3.0, which depends on
        FirebaseFirestore (~> 9.3.0)

こうなった場合の対処法を紹介します。

\ 世界最大級のオンライン学習サービス /

目次

結論:バージョンをアップデートして解決

//アップデート後「8.15.0」>「9.3.0」
pod 'FirebaseFirestore', :git => 'https://github.com/invertase/firestore-ios-sdk-frameworks.git', :tag => '9.3.0'

原因は公式ドキュメントで使用されているバージョンが古かったためエラーが発生。

エラーメッセージ通りバージョンを「8.15.0」>「9.3.0」にアップデートしたら解決。同じようなエラーが発生した場合はエラーメッセージで指定されたバージョンに更新してみてください。

一緒に読みたい

参考

  • URLをコピーしました!
目次